GrabDuck

Upgrading CentOS 6.5 to CentOS 7.2

:

Result table with checks and their results for main contents :

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -

| Bacula Backup Software                                                                      | notapplicable      |

| PostgreSQL upgrade content                                                                  | notapplicable      |

| GNOME Desktop Environment underwent several design modifications in CentOS 7 release        | notapplicable      |

| KDE Desktop Environment underwent several design modifications in CentOS 7 release          | notapplicable      |

| several graphic drivers not supported in CentOS 7                                          | notapplicable      |

| several input drivers not supported in CentOS 7                                            | notapplicable      |

| Names , Options and Output Format Changes in arptables                                      | notapplicable      |

| BIND9 running in a chroot environment check .                                                | notapplicable      |

| BIND9 configuration compatibility check                                                    | notapplicable      |

| Move dhcpd / dhcprelay arguments from / etc / sysconfig / * to * . service files                    | notapplicable      |

| DNSMASQ configuration compatibility check                                                  | notapplicable      |

| Dovecot configuration compatibility check                                                  | notapplicable      |

| Net - SNMP check                                                                              | notapplicable      |

| Squid configuration compatibility check                                                    | notapplicable      |

| Added and extended options for BIND9 configuration                                          | notapplicable      |

| Added options in DNSMASQ configuration                                                      | notapplicable      |

| w3m not available in CentOS 7                                                              | notapplicable      |

| report incompatibilities between CentOS 6 and 7 in qemu - guest - agent package                | notapplicable      |

| Removed options in quota tools                                                              | notapplicable      |

| restore custom selinux configuration                                                        | notapplicable      |

| samba shared directories selinux                                                            | notapplicable      |

| CUPS Browsing / BrowsePoll configuration                                                      | notapplicable      |

| FreeRADIUS Upgrade Verification                                                            | notapplicable      |

| bind - dyndb - ldap                                                                            | notapplicable      |

| Identity Management Server compatibility check                                              | notapplicable      |

| IPA Server CA Verification                                                                  | notapplicable      |

| OpenLDAP / etc / sysconfig and data compatibility                                              | notapplicable      |

| Configuration for quota_nld service                                                        | notapplicable      |

| Disk quota netlink message daemon moved into quota - nld package                              | notapplicable      |

| SSSD compatibility check                                                                    | notapplicable      |

| Clvmd and cmirrord daemon management .                                                      | notapplicable      |

| Removal of scsi - target - utils                                                                | notapplicable      |

| Configuration for warnquota tool                                                            | notapplicable      |

| Disk quota tool warnquota moved into quota - warnquota package                                | notapplicable      |

| Quorum implementation                                                                      | notapplicable      |

| fix krb5kdc config file                                                                    | notapplicable      |

| cgroups configuration compatibility check                                                  | notapplicable      |

| Ruby 2.0.0                                                                                  | notapplicable      |

| SCL collections                                                                            | notapplicable      |

| NIS ypbind config files back - up                                                            | notapplicable      |

| NIS Makefile back - up                                                                        | notapplicable      |

| NIS server maps check                                                                      | notapplicable      |

| NIS server MAXUID and MAXGID limits check                                                  | notapplicable      |

| NIS server config file back - up                                                              | notapplicable      |

| several kernel networking drivers not available in CentOS 7                                | pass                |

| several kernel storage drivers not available in CentOS 7                                    | pass                |

| Reusable Configuration Files                                                                | pass                |

| NTP configuration                                                                          | pass                |

| Information on time - sync . target                                                            | pass                |

| OpenSSH sshd_config migration content                                                      | pass                |

| Luks encrypted partition                                                                    | pass                |

| Architecture Support                                                                        | pass                |

| Debuginfo packages                                                                          | pass                |

| Cluster and High Availability                                                              | pass                |

| Read Only FHS directories                                                                  | pass                |

| In - place Upgrade Requirements for the / usr / Directory                                      | pass                |

| CA certificate bundles modified                                                            | pass                |

| Developer Tool Set packages                                                                | pass                |

| Hyper - V                                                                                    | pass                |

| Check for ethernet interface naming                                                        | pass                |

| User modification in / etc / rc . local and / etc / rc . d / rc . local                                  | pass                |

| Plugable authentication modules ( PAM )                                                      | pass                |

| Python 2.7.5                                                                                | pass                |

| System kickstart                                                                            | pass                |

| Check for usage of dangerous range of UID / GIDs                                              | pass                |

| Incorrect usage of reserved UID / GIDs                                                        | pass                |

| MySQL configuration                                                                        | informational      |

| Migration of the MySQL data stack                                                          | informational      |

| Compatibility Between iptables and ip6tables                                                | informational      |

| VCS repositories                                                                            | informational      |

| Removed options in coreutils binaries                                                      | informational      |

| Removed options in gawk binaries                                                            | informational      |

| Removed options in netstat binary                                                          | informational      |

| GMP library incompatibilities                                                              | informational      |

| CVS Package Split                                                                          | informational      |

| httpd configuration compatibility check                                                    | informational      |

| File Systems , Partitions and Mounts Configuration Review                                    | informational      |

| Sonamebumped libs                                                                          | informational      |

| SonameKept Reusable Dynamic Libraries                                                      | informational      |

| Removed . so libs                                                                            | informational      |

| Foreign Perl modules                                                                        | informational      |

| YUM                                                                                        | informational      |

| Replaced rpms                                                                              | fixed              |

| package downgrades                                                                          | fixed              |

| OpenSSH sysconfig migration content                                                        | fixed              |

| State of LVM2 services .                                                                    | fixed              |

| device - mapper - multipath configuration compatibility check                                  | fixed              |

| Configuration Files to Review                                                              | needs_inspection    |

| File Lists for Manual Migration                                                            | needs_inspection    |

| Changes related to moving from MySQL to MariaDB                                            | needs_inspection    |

| Obsoleted rpms                                                                              | needs_inspection    |

| Binary rebuilds                                                                            | needs_inspection    |

| Packages not signed by CentOS                                                              | needs_action        |

| Removed rpms                                                                                | needs_action        |

| General                                                                                    | needs_action        |

| Content for enabling and disabling services based on CentOS 6 system                        | needs_action        |

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -

Tarball with results is stored here / root / preupgrade - results / preupg_results - 160124125957.tar.gz .

The latest assessment is stored in directory / root / preupgrade .

Summary information :

We found some potential in - place upgrade risks .

Read the file / root / preupgrade / result . html for more details .

Upload results to UI by command :

e . g . preupg - u http : //127.0.0.1:8099/submit/ -r /root/preupgrade-results/preupg_results-*.tar.gz .